[Help] "BootMGR is missing" after Debian 9 Install
#1
I've researched and researched to try to find a solution but everything I've tried hasn't worked.

I had Windows 10 installed alone on my main gaming PC. I shrunk my volume and now dual boot Debian 9 alongside.
The annoying thing is, I keep getting "BootMGR is missing" after selecting the Debian partition to boot from in my boot loader in BIOS. I just want the GRUB boot loader to function properly.

Information after running "fdisk -l"-

Code:
Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 6E7847F6-1C59-4728-A38D-F83121B6E5BA

Device          Start        End    Sectors   Size Type
/dev/sda1        2048     923647     921600   450M Windows recovery environment
/dev/sda2      923648    1126399     202752    99M EFI System
/dev/sda3     1126400    1159167      32768    16M Microsoft reserved
/dev/sda4     1159168 1910819163 1909659996 910.6G Microsoft basic data
/dev/sda5  1951780864 1953521663    1740800   850M Windows recovery environment
/dev/sda6  1910820864 1914726399    3905536   1.9G Linux swap
/dev/sda7  1914726400 1914728447       2048     1M BIOS boot
/dev/sda8  1914728448 1951780863   37052416  17.7G Linux filesystem

Partition table entries are not in disk order.


Disk /dev/sdb: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x73696d20

Device     Boot      Start        End    Sectors   Size Id Type
/dev/sdb1       1919230059 6204919772 4285689714     2T  a OS/2 Boot Manager
/dev/sdb2        544829025 1089655755  544826731 259.8G 65 Novell Netware 386
/dev/sdb3        168653938  168653938          0     0B 65 Novell Netware 386
/dev/sdb4       2885681152 2885734080      52929  25.9M  0 Empty

Partition table entries are not in disk order.

Information after running "df"-
Code:
Filesystem     1K-blocks    Used Available Use% Mounted on
udev             4052468       0   4052468   0% /dev
tmpfs             819432    9600    809832   2% /run
/dev/sda8       18104144 5297196  11864256  31% /
tmpfs            4097152   34488   4062664   1% /dev/shm
tmpfs               5120       4      5116   1% /run/lock
tmpfs            4097152       0   4097152   0% /sys/fs/cgroup
tmpfs             819428       4    819424   1% /run/user/110
tmpfs             819428      16    819412   1% /run/user/1000
I don't see anything boot mounted, could that be the problem?
Reply
#2
Use WindowsCD to Repair Computer. And then Advenced Options and choose Command Prompt.
Use following command:
bootrec /scanos
bootrec /fixmbr
bootrec /fixboot
bootrec /rebuildbcd
Reply
#3
(07-22-2018, 06:04 PM)HonestCloud Wrote: Use WindowsCD to Repair Computer. And then Advenced Options and choose Command Prompt.
Use following command:
bootrec /scanos
bootrec /fixmbr
bootrec /fixboot
bootrec /rebuildbcd

I'm not having issues on the Windows side or booting into Windows at all. I only get that error when booting into Debian.
Reply
#4
Make sure you have:
1) Fast boot disabled: https://www.tenforums.com/tutorials/4189...-10-a.html
2) Make sure GRUB is installed. Should have installed this together with Debian.
3) Boot like you normally do, to C:\ and you will get a grub meny to choose your OS.

And yeah ^ Ditto. I don't know much about windows but that might help restoring your startup records and all that.
Reply
#5
(07-22-2018, 06:57 PM)Insider Wrote: Make sure you have:
1) Fast boot disabled: https://www.tenforums.com/tutorials/4189...-10-a.html
2) Make sure GRUB is installed. Should have installed this together with Debian.
3) Boot like you normally do, to C:\ and you will get a grub meny to choose your OS.

And yeah ^ Ditto. I don't know much about windows but that might help restoring your startup records and all that.

1) I have hibernation disabled, so fast boot is disabled.
2) I definitely have GRUB installed. Can edit config and run update-grub.
3) Try to boot normally, but it boots straight into Win 10, so I have to go into my boot menu in BIOS with F12 and choose the partition Debian is on. When I do that, I'm give the bootmgr is missing error. I can still boot into Debian when I hit a key to "restart"
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  [Tutorial] How To: Install Debian 9 (Stretch) system32 0 5,381 07-22-2018, 07:59 PM
Last Post: system32
  Basic Security Practises [Harden Debian 8.0] Insider 3 8,656 02-09-2018, 05:25 PM
Last Post: k1tsune
  Finally Upgraded to Debian NO-OP 7 8,474 08-09-2017, 01:53 PM
Last Post: Insider
  Help choosing my linux OS Knife Boss 12 12,383 08-09-2017, 01:24 PM
Last Post: Kontu