why isn't Pidgin working?
#1
This is a really embarrassing thing for me to post on GreySec because it probably shows how little I actually know but, since honesty is key to a good life, here is my embarrassing thread.

So last time I set up Pidgin on Ubuntu it worked perfectly after I played around with it for a while. Now it suddenly says:

Code:
qmark@xmpp.jp/xmpp disconnected
unable to connect

This is ridiculous. It shouldn't just be "unable to connect." I ideally need to have access to my own XMPP account.

Why is it doing this?

I'm continuing to research it. I feel like it ideally shouldn't do this. And it worked last time I connected to XMPP.

Whether or not I enable Tor doesn't seem to have any bearing on whether or not it connects.
Reply
#2
Did you change your password? Or modified your account in some way? Are you sure the Tor Daemon is running when you try to route through Tor? If so, is your control port 9050 or 9150?

Is all else fails, you can simply delete that account and set a brand new one up over at xmpp.is or xmpp.jp both should be good. Make sure to double check your settings.
Reply
#3
(09-07-2020, 10:35 PM)Vector Wrote: Did you change your password? Or modified your account in some way? Are you sure the Tor Daemon is running when you try to route through Tor? If so, is your control port 9050 or 9150?

Is all else fails, you can simply delete that account and set a brand new one up over at xmpp.is or xmpp.jp both should be good. Make sure to double check your settings.

I'm turned tor on with "sudo service start tor" command, tried it, didn't work. Turned tor off with "sudo service stop tor", tried it, didn't work.

I also tried anonsurf to run Tor and it didn't work either.

The port is 9050. Should it be 9150?

I know that 9150 is better for things like Tor bridges because that's what they told me to do when I needed advice on Tor bridges.

What would you recommend?

Is 9150 the new 9050 and more up to date than 9050? Is that the point behind what your saying?

By the way, thank you for the advice.
Reply
#4
(09-08-2020, 04:31 AM)QMark Wrote: I'm turned tor on with "sudo service start tor" command, tried it, didn't work. Turned tor off with "sudo service stop tor", tried it, didn't work.

I also tried anonsurf to run Tor and it didn't work either.

The port is 9050. Should it be 9150?

I know that 9150 is better for things like Tor bridges because that's what they told me to do when I needed advice on Tor bridges.

What would you recommend?

Is 9150 the new 9050 and more up to date than 9050? Is that the point behind what your saying?

By the way, thank you for the advice.

The practical approach would be to open up your terminal and paste these commands.

Code:
sudo ss -tops |grep tor

You can see on which port things are connecting to Tor on. Set your proxy settings accordingly.

[Image: zYaVVsa.png]

I suppose if your control port is on 9150, change the port value. If that doesn't do the trick, you could try to set it as a SOCKS5 proxy. Check the status of your Tor service with these commands to see if they're working ok.


Code:
sudo systemctl status tor

Or these ones.

Code:
sudo service tor status

If Tor is running and your proxy settings have been configured properly, i'd try creating a new account. Oh and make sure that you don't have conflicting proxy rules that are account specific, have the account specific settings use the global proxy settings.
Reply
#5
Here is the results I get:

Code:
greg@greg-Q525UAR:~$ sudo ss -tops |grep tor
[sudo] password for greg:
ESTAB   0        0             192.168.0.16:46742         38.229.33.152:https    users:(("tor",pid=925,fd=12))                                                  
greg@greg-Q525UAR:~$ sudo service tor status
● tor.service - Anonymizing overlay network for TCP (multi-instance-master)
     Loaded: loaded (/lib/systemd/system/tor.service; enabled; vendor preset: e>
     Active: active (exited) since Tue 2020-09-08 12:46:18 PDT; 10min ago
    Process: 750 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
   Main PID: 750 (code=exited, status=0/SUCCESS)

Sep 08 12:46:18 greg-Q525UAR systemd[1]: Starting Anonymizing overlay network f>
Sep 08 12:46:18 greg-Q525UAR systemd[1]: Finished Anonymizing overlay network f>
lines 1-8/8 (END)

Hi, does this mean I should make a new account? What should I do from here? Should I switch to a SOCKS proxy?

Hold on, here is a screenshot of my settings for the pidgin account:

https://gofile.io/d/q1uiC0
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  how to get Telnet working on this network? QMark 16 4,133 07-02-2020, 07:08 PM
Last Post: QMark
  Why do bug bounty hunters on average have more skill? QMark 3 6,176 08-12-2018, 04:16 PM
Last Post: hworth
  why don't internal networks work like this? QMark 1 4,098 04-18-2018, 09:42 AM
Last Post: Brandonwheel
  Why is GreySec being censored by the government? QMark 3 4,789 03-14-2018, 12:33 AM
Last Post: Insider